16th May 2017

Web Hosting demeter.safeukdns.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update @ 11:19 a.m. BST: The server became unresponsive and was rebooted to restore service. Upon reboot it initiated a file system integrity check, it is currently under way.
  • Update @ 11:26 a.m. BST: The server is online and available for use.