26th November 2018

Email System Outage

We are aware that there are issues affecting our email service. We are working to get them resolved.

*** UPDATE *** At 18:10 AM, our admins notified us the issue regarding webmail logins has been corrected. If you are still seeing issues with your webmail login, please contact our support team.

***UPDATE *** At 19:46 PM, our admins notified us the previous issue has resurfaced. They are investigating and will update us again when they have an update.

*** UPDATE *** At 22:00, our admins updated the status for this issue to resolved, once again.