18th December 2018

CHI Email

Our operations team is investigating an issue affecting some users on CHI email. Users may experience issues when sending/receiving, or logging into Webmail. We will update when we have more information.

Update the issue has been identified and accounts should be recovering. We are still monitoring the situation.

Update the issue concerning webmail accounts has been resolved. Please contact us if you are needing any technical assistance with email. https://uk2.net/support