7th March 2019

Shared Hosting poseidon.safeukdns.net

We are aware that there are issues affecting this server. We are working to get them resolved.

Update @ Thu Mar 7 11:55:00 GMT 2019: We have experienced a hardware issue and had to perform an emergency maintenance to resolve it. The server is booting up now, it is currently performing a file system integrity check and will be available shortly.

Update @ Thu Mar 7 12:01:16 GMT 2019: The file system check is at 48% complete.

Update @ Thu Mar 7 12:16:05 GMT 2019: The file system check is at 78% complete.

Update @ Thu Mar 7 12:27:28 GMT 2019: The server is online and available for use.