18th March 2019

CHI Email Outage

We are currently seeing issues with both incoming and outgoing email on our CHI email system. We are still investigating the cause and will post updates as they become available.

UPDATE We are happy to report the incidents on CHI email related to slow webmail login along with inbound/outbound mail delays have been resolved. We will continue to monitor the status, we will provide our next update shortly.

UPDATE We are happy to report CHI email services are behaving normally. This is now considered resolved.