9th June 2019

Web Hosting chimail.uk2.net

We are experiencing an issue with our SSL certificate on chimail.uk2.net. You may see warning messages or errors in your mail client when trying to send/receive emails. We are working with our SSL provider to re-issue the SSL certificate as soon as possible to clear this up.

• Update June 9, 2019, 3:17 PM BST Apologies for the inconvenience and delay in this matter. We are working to get this resolved as soon as possible. If you need further assistance please contact support at https://uk2.net/support

• Update June 9, 2019, 4:19 PM BST Currently working with administrators to resolve the SSL certificate for chimail.uk2.net. For anyone using an email client, mail.hostedemail.com is a working alternative server name. We will post another update as soon as we have more information.

• Update June 9, 2019, 5:34 PM BST A new SSL certificate has been installed on chimail.uk2.net, and the email server is now back online. Apologies for the inconvenience caused by this incident. If you have further questions, feel free to contact our support team at https://uk2.net/support