23rd August 2019

Partial Email Outage

Date: 23 August 2019 Start time: 09.35 AM BST

RESOLVED - 13:36 BST: Our technical teams have fixed the issue with our hosted email service. Please accept our apology for any inconvenience or frustration we may have caused.

UPDATE - 12:53 BST: We are still investigating this matter where users in Europe/South Africa are unable to connect to our hosted email service.

UPDATE: Our technical teams have been engaged and we are currently working to resolve the issue affecting POP3, IMAP and Webmail connections to mail.uk2.net.

We are currently investigating an issue preventing some of our customers from accessing mail.uk2.net. We apologise for any inconvenience experienced during this period and we will keep you updated on our progress.