31st January 2020

Hosted Email Incident - Webmail/email client login

Title: Incident - Webmail/email client login Date: Friday, Jan 31st, 06:54 GMT

We are investigating an issue preventing some users on our hosted email from accessing their email via Webmail or client programs. We currently see this is affecting a small group of accounts. Our operations team has been engaged, and we apologise for any inconvenience this may cause.

We will provide an update once we have additional information.

If you have any questions or concerns, please contact our support team.

  • Update @ 09:03 GMT - This issue has been identified, and a fix has been implemented. We are currently monitoring to see if there are any accounts still experiencing this.

  • Update @ 10:08 GMT - We have continued monitoring this but have found no accounts with this login issue. This issue is resolved.