18th March 2020

Hosted Email Hosted email login issues

Title: Hosted email login issues Date: Wednesday, 18th March 2020, 16:00 UTC Event type: Minor email outage

We are currently investigating reports of not being able to access webmail, or email via mail clients, which is currently affecting a small subset of our hosted email accounts.

  • Update @ 18:43 UTC - The affected node was restored and services are healthy as of now. The process of increasing the system capacity is still work in process and should not impact current operations. We will keep monitoring.

  • Update @ 23:05 UTC - This issue has been resolved. We apologise for any inconveniences this may have caused.