22nd January 2024

Hosted Email POP, Imap, Webmail mail access.

Title POP, Imap, Webmail mail access.

Date Monday 22nd January 2024

Start time 12.05 GMT

We are currently investigating reports of intermittent issues with our mail service whereby some customers may no longer be able to access POP, Imap, and Webmail services

We sincerely apologize for the inconvenience this will cause our customers.

We are working hard to resolve the email issue for you ASAP and will provide further updates when they become available via this status page

Update @01:50 GMT - Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @ 02:55 GMT The Functionality of the email service has been restored. Our engineering team is continuing to monitor the issue to ensure the service remains stable.

Update @ 03:30 GMT This issue has been resolved