15th July 2021

Hosted Email Hosted Email - Connection drops

Title Hosted Email - Connection drops
Date Thursday 15 July 2021
Start time 09:43 BST

We are currently experiencing connection drops for a small set of email accounts on the Hosted Email platform. Technical teams have been engaged and are investigating as a priority, and will provide updates as they are available.
We apologise for any inconvenience this may cause.

  • Update @ 11:49 BST - Technical teams have identified that connections to Webmail and to mail clients over IMAP are affected for some clients. The teams continue to investigate this as a priority.
  • Update @ 13:22 BST - The engineering team has identified the issue within the Hosted Email system and is currently working on resolving the issue.
  • Update @ 16:46 BST - The engineers had successfully implemented a fix, and are bringing services back online in a controlled manner to resolve the issue.
  • Update @ 17:48 BST - The engineering team continues to monitor the situation to ensure that the affected mail services are fully back online and remain stable.
  • UPDATE - 21:00 BST: ** ** RESOLVED A fix has been implemented and the hosted email web login, is now accessible. We apologise for any inconvenience this may have caused.