18th August 2022

Hosted Email Hosted Email Webmail

Title Hosted Email Webmail Issues Date Thursday 18th August 2022 Start time 07:54 BST

We are currently experiencing an incident that is impacting our Hosted Email Webmail. Our Technical teams have been engaged and are investigating as a priority. We apologise for any inconvenience this may cause.

  • Update @ 09:51 BST - Some users may experience intermittent errors when sending / receiving email, logging in to webmail, changing email passwords and creating new email addresses. Mail engineering teams are continuing investigations. We will update as soon as we have more information. We appreciate your patience.

  • Update @ 10:37 BST - Engineering teams are continuing to investigate the issue. Further updates will be provided as they become available

  • Update @ 12:01 BST - Our engineering teams have implemented a fix to restore service, this incident is in monitoring as services restore to normal operation. Thank you for your continued patience.

  • Update @ 13:36 BST - Our engineering team are continuing to investigate delays on our hosted email service. Further updates will be provided as they become available.

  • Update @ 15:02 BST - Our engineering teams have identified the issue and are working to resolve the problem as quickly as possible.

  • Update @ 17:26 BST - Our engineering teams are continuing to resolve the problem. Thank you for your continued patience.

  • Update @ 19:00 BST - We are continuing to work towards restoring service. Further updates will be provided as they become available.

  • Update @ 20:30 BST - Email services remain intermittent, progress continues to restore the services. We will provide updates as soon as we have more information. We appreciate your patience

  • Update @ 22:00 BST - The email services have been restored however some users may experience intermittent delays in receiving emails during this time due to the backlog of emails. Our engineering team is continuing to monitor the issue. Thank you for your continued patience.

  • Update @ 23:30 BST - This issue is resolved the email service is now stable and functioning normally. We apologize for any inconvenience this may have caused.