7th February 2024

persephone.safeukdns.net Unavailable

Title persephone.safeukdns.net Unavailable
Date Wednesday 7th February 2024
Start time GMT 19.10

We are currently experiencing an incident on the server persephone.safeukdns.net. Our Technical teams have been engaged and are investigating as a priority.

Update 19.45 GMT Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update 20.05 GMT We continue to monitor the server persephone.safeukdns.net.

Update 21.00 GMT This issue has now been resolved.