2nd March 2019

Shared Hosting eos.safeukdns.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update Sat Mar 2 11:05:23 GMT 2019 The server currently performing a file system checks and will be available shortly.
  • Update Sat Mar 2 11:56:44 GMT 2019 The server is back online.