1st August 2019

Shared Hosting Partial Email Outage

We are currently investigating an issue preventing some of our customers from accessing mail.uk2.net. We apologise for any inconvenience experienced during this period and we will keep you updated on our progress.

  • Update: We are still investigating the issue preventing some of our customers from accessing mail.uk2.net. We apologise for any inconvenience experienced during this period and we will keep you updated on our progress.
  • Update: Emails are now being delivered to customer mailboxes with some delay. We apologise for any inconvenience experienced during this period and we will keep you updated on our progress.
  • Update: Email services have now been fully restored as of 21.15 01/08/2019.