1st August 2017

Web Hosting Email Services - Delivery Delays

Our operations team is currently investigating inbound mail delivery delays for email services. The delay time will vary depending on the sending mail providers retry policy. For providers with typical retry policies the delay is under 15 minutes.

Update @ Tue Aug 1 13:30:00 BST 2017: The expected average inbound mail delivery delay has increased to between 30 and 60 minutes. Our operations team continues to work towards alleviating the issue.

Update @ Tue Aug 1 21:20:00 BST 2017: We are happy to report that the inbound email delays and webmail slowness issues have been resolved. Thank you for your patience during this event, and we apologise for the inconvenience.