12th February 2020

Interruption of power supply in London Datacentre

UPDATE: There was an interruption to some of the power supply in DC5 which has now been restored. Some of the services are still down and we are working to bring them back online as soon as possible.

Resolved: Our network department have resolved the issue all the servers are back up now. Kindly accept our apologies for any inconvenience that may have caused due to this issue.