28th April 2020

Hosted Email Email delivery issues

Title: Email delivery issues Date: Tuesday 28th April, 2020 Start time: 08:82 AM BST

We are currently investigating an issue on our Hosted Email Services. A small group of users may experience Inbound/Outbound delivery issues during this time.

  • Update @ 09:17 BST - We've found the segment associated with the affected accounts and our NOC Team is working to restore access.
  • Update @ 09:37 BST - A fix has been implemented and we are monitoring the results.
  • Update @ 10:32 BST - We've resolved the issue with our Hosted Email Services and all mailboxes should now be functioning normally.

If you have any questions or concerns, please contact our support team.