5th June 2020

Hosted Email Hosted Email Login Issue

Title: Hosted email login issues
Date: Friday 5th June 2020, 08:46 BST
Event type: Minor email outage

We are currently investigating reports of not being able to access some mail accounts via webmail or mail clients, which is currently affecting a small subset of our hosted email accounts.

  • Update @ 10:00 BST - Our Network Operations Team confirmed this affected all users on one of our mailstores, and has since resolved the issue. We will continue to monitor the stability of this and post further updates to confirm that this incident has been fully resolved.
  • Update @ 17:00 BST - We have monitored the stability and can confirm that this incident is fully resolved.