23rd August 2017

Web Hosting CHI Mail - SMTP Outbound

Investigating - We are currently experiencing issues with our CHI Mail SMTP outbound servers. Users will intermittently experiencing slowness and SMTP errors when sending emails. Our operations team is currently investigating the issue, and we will provide further updates as soon as they become available.

We apologise for the inconvenience.

Resolved - We are happy to report that we have resolved the issue with our CHI Mail SMTP outbound servers. Thank you for your patience, and we apologise for the inconvenience.