11th September 2017

Shared Hosting demeter.safeukdns.net

We are aware that there are issues affecting this server. We are working to get them resolved.

Update @ Mon Sep 11 09:36:40 BST 2017: The server became unresponsive and has been rebooted to restore service. It is currently undergoing a file system integrity check, this process may take 30-40 minutes to complete.

Update @ Mon Sep 11 09:45:51 BST 2017: The server is online and available for use.