16th December 2020

Ticketing system outage

We are aware of an issue with our online ticketing system.

Date: Tuesday, December 15th, 2020
What is the impact: Unavailability to submit or view support tickets.

Our engineers are working to resolve this as a matter of urgency. Thank you for your patience and understanding.

  • UPDATE @ 20:00 GMT: - Our online ticketing system is back online.
  • UPDATE Wednesday, December 16th, 2020 @ 05:34 GMT: - Our online ticketing system is currently unavailable, we apologize for the inconvenience this may cause.
  • UPDATE Wednesday, December 16th, 2020 @ 07:26 GMT: - Access to our online ticketing system has been fully restored.