27th October 2017

Shared Hosting demeter.safeukdns.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update Fri Oct 27 15:30:19 BST 2017: The server experienced a kernel panic and is being rebooted now.
  • Update Fri Oct 27 16:32:23BST 2017: The server is online and available for use.