11th July 2021

Hosted Email Hosted Email login issues

Title Hosted Email Login issue

Date 11/07/2021

Start time 09:17 BST

We are currently experiencing an incident that is impacting our Hosted Email Web Login. Our Technical teams have been engaged and are investigating as a priority.

UPDATE - 09:30 BST Technical teams is continuing to investigate the issue. Further updates will be provided as they become available

UPDATE - 09:40 BST Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience

UPDATE - 09:56 BST Resolved Our technical teams have completed the investigation and all mail services are resumed to fully operational with no further login issues. we are monitoring the state, Jul 11, 08:56 BST. We apologize for any inconvenience this may have caused.