25th February 2022

Hosted Email Hosted Email Sending/Receiving

Title Hosted Email Sending/Receiving
Date Friday 25 02 2022
Start time 17:05 GMT

Some customers may be experiencing errors when sending/receiving emails. Technical teams are currently investigating as a priority. Further updates will be posted when available. We apologise for any inconvenience this may cause.

UPDATE - 20:20 GMT: Technical team has Identified the issue. However, there are still issues being worked on. We will provide updates as they become available.

UPDATE- 23:00 GMT: Technical team is still working to resolve this issue. We will provide further updates as they become available.

UPDATE - 26/02/2022 01:12 GMT: Normal mail service has resumed. Apologies for the inconvenience.