3rd March 2022

Hosted Email Hosted Email Sending/Receiving

Title Hosted Email Sending/Receiving
Date Thursday 3rd March 2022
Start time 23:40 GMT

Some customers may be experiencing errors when sending/receiving emails on our Hosted Email (ChiMail) platform. Technical teams are currently investigating as a priority. Further updates will be posted when available. We apologise for any inconvenience this may cause.

UPDATE - 01:00 GMT: Technical team continuing to investigate this issue. We will provide further updates as they become available.
UPDATE - 04:20 GMT: Normal mail service has resumed. Apologies for the inconvenience.