16th July 2022

Hosted Email Sending/Receiving

Title Hosted Email Sending/Receiving
Date Saturday 16 July 2022
Start time 03:52 BST

We are currently experiencing an incident that is impacting our Hosted Email Webmail and mail clients. Our Technical teams have been engaged and are investigating as a priority. We apologise for any inconvenience this may cause.

Update Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @04:45 BST This issue has now been resolved.