Back to overview
Maintenance
SSL Certificate renewals through CHI
Jun 6, 2026 at 10:00am UTC
–
Jun 6, 2026 at 10:00pm UTC
Affected services
CHI (Control Panel) Status
Resolved
Jun 6, 2026 at 10:00pm UTC
Maintenance ended
Affected services
Created
Jun 6, 2026 at 10:00am UTC
Planned maintenance is currently ongoing with one of our SSL issuers. As a result, any renewals of existing SSL certificates may fail, and the ability to download existing SSL certificates will fail.
We expect all services to resume normal operation immediately after the maintenance window.
Thank you for your patience.
Affected services