3rd February 2018

Phone System Partial Outage

Billing and Sales Phone Connection Issues February 3, 2018

We are experiencing connection issues when clients try to call billing and sales. There are no issues when trying to call technical support. To connect with our billing and sales team please submit a ticket or chat with us live. For more information on contacting support: https://www.uk2.net/support/

Thank you for your patience as we work through this issue.

Update February 7: We are still investigating this issue.

Update February 9: This has been resolved by our Network Engineers. Billing and Sales phone connection is no longer experiencing any issues.