9th February 2018

Phone System Phone System Performance Issues

Title: Phone System Performance Issues
Date: Friday February 09, 2018 Start time: 08:12 PM GMT

We have identified issues with our phone system and are working to resolve this as soon as possible.

For immediate assistance, please contact us by submitting a ticket or using live chat.

Update: 10:03 PM MST. We have identified the issue and will continue monitoring this closely to ensure this is resolved. Thank you for your patience and understanding.

Update: 01:49 AM MST. The problem has been resolved.