12th February 2018

Web Hosting Email Services

We are currently experiencing an unexpected issue with our email cluster causing intermittent connectivity issues to the mail servers. Our engineers are currently investigating this issue.

Update @ Mon Feb 12 14:49:19 GMT 2018: Our operations team is continuing to work on the issues impacting the email cluster performance.

Update @ Mon Feb 12 16:59:21 MST 2018: The issues we were experiencing are now resolved. Thank you for your patience in this matter.