Back to overview
Degraded

CHI Ticket Creation

Apr 2, 2026 at 11:22am UTC
Affected services
CHI (Control Panel) Status

Resolved
Apr 2, 2026 at 4:09pm UTC

UPDATE We are now seeing normal function with tickets and are marking this issue as resolved. We do apologise for any inconvenience.

Created
Apr 2, 2026 at 11:22am UTC

We are currently experiancing an unexpected outage affecting our CHI ticketing system. As a result, customers may be unable to submit new tickets or access existing tickets through their CHI account.

This is being actively investigated and we are working to restore full functionality as quickly as possible.

Customers can still use our Live Chat support or contact us via email during this time.