Back to overview
Downtime

Access to chi.uk2.net

May 7, 2026 at 1:10pm UTC
Affected services
CHI (Control Panel) Status

Resolved
May 7, 2026 at 1:16pm UTC

The issue affecting connectivity via chi.uk2.net has now been fully resolved. All affected services are operating normally.

We apologise for any disruption cause. Thankyou for your patience while this was investigated.

Created
May 7, 2026 at 1:10pm UTC

We are currently aware of an issue affecting access to chi.uk2.net.

During this time, customers may be unable to log in to their CHI control panel accounts. Our team is investigating the cause and working to restore access as quickly as possible.

We will provide further updates as soon as more information becomes available.

Thank you for your patience.